eCampus - West Virginia University

Computer Requirements and Supported Browsers

Compatible Browsers

Only one browser is required to access eCampus. However, it is wise to have at least two ready to go at any one time in the event the primary browser fails. In Windows systems, it is recommended to have Internet Explorer, Firefox and Chrome operational. For OS X (Mac) systems, Safari, Firefox and Chrome are recommended. These browsers may be downloaded from the icons below. The supported technologies statements are specifically relevant to WVU eCampus.

Browser Downloads

Computer Requirements

Colleges, departments or degree programs that have specific computer requirements are listed here. Students can contact their departments or advisors for more information.

Recommended Specs

Web Browsers



Microsoft Windows

Operating System Internet
Explorer 11 1
Internet
Explorer 10 1
Internet
Explorer 9 1
Chrome
(Stable Channel)
Mozilla Firefox
(Final Release Channel) 2
Windows 7 (32-bit) Supported Supported Supported Supported Supported
Windows 7 (64-bit) Supported Supported Supported Supported Supported
Windows 8 (32-bit) Supported Unsupported by Microsoft Unsupported by Microsoft Supported Supported
Windows 8 (64-bit) Supported Unsupported by Microsoft Unsupported by Microsoft Supported Supported


Mac

Operating System Chrome 3 Apple Safari 6.0 Apple Safari 7.0 Apple Safari 8.0 Mozilla Firefox (Final Release Channel) 2
Mac OS X 10.8 Lion 4 Supported Supported Unsupported by Apple Unsupported by Apple Supported
Mac OS X 10.9 Lion Supported Unsupported by Apple Supported Unsupported by Apple Supported
Mac OS X 10.10 Yosemite Supported Unsupported by Apple Unsupported by Apple Supported Supported

1Internet Explorer is only supported in Standards Mode.

2Firefox support: due to the auto-update feature of Firefox, support is based on the version available at the time of testing. Learn 9.1 Q4 2015 was tested with Firefox 31+

3Chrome support: due to the auto-update feature of Chrome, support is based on the version available at the time of testing. Learn 9.1 Q4 2015 was tested with Chrome 36+. Google Chrome versions 42+ do not support NPAPI-type plug-ins, including Java plug-ins and many media browser plug-ins. eCampus doesn't support these browsers for use with the multiple-file upload interface, or embedded media that require NPAPI plug-ins for viewing.

4Note on OSX 10.8+ Java is no longer shipped as part of the OS install and must be downloaded and installed by users on request of application/applet - this is a one time action on the part of the user.

NOTE: If you have the latest update for Firefox, Internet Explorer or Chrome, you may find that the eCampus browser check gives a red X for the general checkup, even when all items on it are green. Do not worry about it, there is often a delay between the release of a new browser version and its inclusion in the browser checker.

Technologies not Supported

The following technologies are not supported in eCampus:

  • Internet Explorer 6, 7, 8
  • Firefox 1.x, 2.0, 3.0, 3.5, and 3.6
  • Safari 2, 3, 4, 5 and any version on Windows
  • Windows XP, Windows 10
  • Mac OSX 10.6 and below
  • Java 5 & 6

Other Support in eCampus

Accessibility and JAWS

Blackboard strives to make all its products as accessible as possible. JAWS 14 and 15 were used during accessibility testing of Learn 9.1 October 2014.

JRE Support

JRE version 7 is the recommended version for features that depend on it. JRE version 8 may work, but could result in unexpected behavior.

On Apple Mac OS X, Google's Chrome browser does not support Java 7 because of incompatibilities between 64-bit Java and 32-bit Chrome. Firefox and Safari browsers do not have this limitation on Mac OS X. Users of the Chrome browser on Mac OS X must configure Java 6 support.